1
Vote

Some of the SSRS reports return an error when opened on SharePoint

description

Hi,

I'm not sure if this is really an issue with the reports, just a problem with Sharepoint-integrated SSRS or something else, but anyway:
  • Sharepoint 2010
  • SSRS 2012
  • Deployed the reports, some work just fine (e.g. dashboard), some (e.g. execution executable duration) return this error:
An error (Unable to read data from the transport connection: The connection was closed.) occurred while transmitting data over the HTTP channel.
An error (Unable to read data from the transport connection: The connection was closed.) occurred while transmitting data over the HTTP channel.
Unable to read data from the transport connection: The connection was closed. 
  • If deployed on a native SSRS, they all work fine.
Any ideas? Thanks!

file attachments

comments

jamiet wrote Sep 11, 2013 at 8:00 AM

Hi,
That does seem rather strange. There is nothing ostensibly different about any of the reports so I'm confused why some would work an some don't. Perhaps the volume of data is the problem (the dashboard report doesn't bring much back across the wire for example). Without more info its hard for me to suggest an avenue of investigation I'm afraid.

regards
Jamie

BDee wrote Sep 11, 2013 at 8:26 AM

Ok, can I can try to provide more info - what sort of info would help to narrow this down? A complete list of which reports work and which don't? Anything else?

Thanks!
BD

jamiet wrote Sep 11, 2013 at 8:53 AM

My suspicion is that this is a connectivity issue somewhere. The error literally means there's something wrong with the communication to the report server, I would check to see if SSRS does any sort of logging of http traffic to see if that uncovers anything. if it does not then your web server will certainly do some sort of logging - this is outside my area of knowledge though I'm afraid.

BDee wrote Sep 11, 2013 at 9:24 AM

Alright, thanks, I'll try to figure it out. In case I do, I'll post it here.